Get in touch
Back
Resolved

Important: Global GCS Issues Impacting Leadspace Services

Started .

API Bulk API Single SmartForms Hubspot Marketo Eloqua Leadspace On Demand https://www.leadspace.com
Created

Leadspace services are back up and running at this time. Google Cloud Services are still experiencing issues per https://status.cloud.google.com/index.html so we will continue to monitor internally.

Leadspace online services were degraded from 11:00am PST to 1:45pm PST.

If you have any questions, please Submit a Support Ticket by visiting https://support.leadspace.com and clicing 'Submit a Request'.

Posted .